Software /
code /
prosody
Diff
plugins/mod_storage_sql.lua @ 10680:19692fc5c106
storagemanager, mod_storage_sql: Rename methods to :get_all() and :delete_all()
author | Matthew Wild <mwild1@gmail.com> |
---|---|
date | Wed, 11 Mar 2020 16:32:41 +0000 |
parent | 10677:0054aec3e8c5 |
child | 10701:929c95e518f0 |
line wrap: on
line diff
--- a/plugins/mod_storage_sql.lua Wed Mar 11 16:29:57 2020 +0000 +++ b/plugins/mod_storage_sql.lua Wed Mar 11 16:32:41 2020 +0000 @@ -230,9 +230,9 @@ return result; end -function map_store:find_key(key) +function map_store:get_all(key) if type(key) ~= "string" or key == "" then - return nil, "find_key only supports non-empty string keys"; + return nil, "get_all only supports non-empty string keys"; end local ok, result = engine:transaction(function() local query = [[ @@ -258,9 +258,9 @@ return result; end -function map_store:delete_key(key) +function map_store:delete_all(key) if type(key) ~= "string" or key == "" then - return nil, "delete_key only supports non-empty string keys"; + return nil, "delete_all only supports non-empty string keys"; end local ok, result = engine:transaction(function() local delete_sql = [[