File

mod_uptime_presence/mod_uptime_presence.lua @ 6177:ce0579449dba

mod_groups_internal: Rename README.markdown to README.md I had exported my last patch a long time ago, back when all READMEs were using .markdown.
author Rémi Bardon <remi@remibardon.name>
date Fri, 31 Jan 2025 01:49:01 +0100
parent 917:d3497b81a3b5
line wrap: on
line source

local st = require"util.stanza";
local datetime = require"util.datetime";

local presence = st.presence({ from = module.host })
	:tag("delay", { xmlns = "urn:xmpp:delay",
		stamp = datetime.datetime(prosody.start_time) });

module:hook("presence/host", function(event)
	local stanza = event.stanza;
	if stanza.attr.type == "probe" then
		presence.attr.id = stanza.attr.id;
		presence.attr.to = stanza.attr.from;
		module:send(presence);
		return true;
	end
end, 10);