File

mod_portcheck/mod_portcheck.lua @ 6177:ce0579449dba

mod_groups_internal: Rename README.markdown to README.md I had exported my last patch a long time ago, back when all READMEs were using .markdown.
author Rémi Bardon <remi@remibardon.name>
date Fri, 31 Jan 2025 01:49:01 +0100
parent 4901:3abbcb8584d2
line wrap: on
line source

module:set_global();
local portmanager = require "core.portmanager";

local commands = module:shared("admin_shell/commands")

function commands.portcheck(session, line)
	for desc, interface, port in line:gmatch("%s(%[?([%x:.*]+)%]?:(%d+))") do
		assert(portmanager.get_service_at(interface, tonumber(port)), desc);
	end
	session.print "OK";
end

function module.unload()
	commands.portcheck = nil;
end