File

mod_block_subscribes/mod_block_subscribes.lua @ 6177:ce0579449dba

mod_groups_internal: Rename README.markdown to README.md I had exported my last patch a long time ago, back when all READMEs were using .markdown.
author Rémi Bardon <remi@remibardon.name>
date Fri, 31 Jan 2025 01:49:01 +0100
parent 926:f88381a39c56
line wrap: on
line source

local allowed_presence_types = { probe = true, unavailable = true };

function filter_presence(event)
	local stanza = event.stanza;
	local presence_type = stanza.attr.type;
	if presence_type == nil or allowed_presence_types[presence_type] then
		return;
	end
	return true; -- Drop
end

module:hook("pre-presence/bare", filter_presence, 200); -- Client sending
module:hook("presence/bare", filter_presence, 200); -- Client receiving